Parallels Plesk Panel System Requirements

Supported Operating Systems

Linux

  • CentOS 6.x
  • CentOS 5.x
  • CloudLinux 6.x
  • CloudLinux 5.x
  • Debian 6.0
  • Debian 7.0
  • openSUSE 12.3 (EOL: September 15, 2014)
  • RedHat Enterprise Linux 6.x
  • RedHat Enterprise Linux 5.x
  • Ubuntu 12.04 Server LTS
  • Ubuntu 10.04 Server LTS (EOL: April 1, 2015)

Windows

  • Windows Server 2008 R2 SP1 (EOL: January 13, 2015)
  • Windows Server 2008 SP2 (EOL: January 13, 2015)
  • Windows Server 2012

BOLD indicates a Parallels-recommended operating system
EOL = End of Life

For more information on the support policies around operating system versions, please see our Parallels Plesk Panel Lifecycle Policy.

Hardware Requirements

For Linux:

  • 512 MB of RAM (1 GB when hosting many accounts; 768 MB minimum when also using Web Presence Builder)
  • 10 GB Hard Disk

For Windows:

  • 1 GB of RAM (2 GB when hosting many accounts)
  • 32 GB Hard Disk

Important Notes

Common

  • A static IP address should be configured in the operating system before installing Parallels Plesk Panel.
  • For upgrades from Plesk 8/9/10 to Plesk 11.x, please run our Environment Pre-Check Script to ensure that your environment and system components are ready to upgrade to Plesk 11. Please see more at http://kb.parallels.com/9436

Linux-Specific

  • Before installing Parallels Plesk Panel software on CloudLinux, you should make sure that the YUM repository on the server is configured for access to CloudLinux Repository.

Windows-Specific

  • For Windows Server 2008, you should add the Web Server role before installation of Plesk. For Windows Server 2003, Internet Information Services (IIS) should be preinstalled with World Wide Web (WWW) Service and File Transfer Protocol (FTP) Service support. Plesk Panel supports IIS 7 native API.
  • Parallels Plesk Panel for Windows can be installed only on NTFS partition.
  • In order for your server to support Server Side Includes (SSI) and Active Server Pages (ASP), and components such as ColdFusion, you need to install these components yourself.
  • If you do not have Windows Installer 4.5 you can download and install it from www.microsoft.com.
  • If you plan to use Microsoft SQL Server support in Parallels Plesk Panel for Windows, the SQL Server should be installed and configured to use standard or mixed security mode. If Microsoft SQL Server is not installed, you can select it to be installed with Parallels Plesk Panel for Windows and configured with administrator name "sa" and a random password

Supported Browsers

  • Firefox 13.0 and above
  • Microsoft Internet Explorer 7, 8, 9, 10
  • Safari 5.0 and above
  • Google Chrome 19.0 and above

Mail Client Requirements

  • Any mail client supporting SMTP, POP or IMAP. Plesk documentation describes setting up MS Outlook, MS Outlook Express, Apple Mail and Mozilla Thunderbird to work with Plesk mail.

Supported Mail Servers

  • Qmail 1.03
  • Postfix 2.5-2.9
  • MailEnable Standard/Professional/Enterprise 6.5
  • SmarterMail 10.0
  • IceWarp (Merak) 10.4

© 1999-2014 Parallels IP Holdings GmbH. All rights reserved.    Terms of Use | Privacy Policy 

Twitter More Sharing Services