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C H A P T E R  1  

Introduction 

In this chapter we’ll talk about the virtual machine technology that is used by Parallels® 
Workstation and will familiarize you with the main characteristics of a virtual machine created 
by Parallels Workstation. 

In This Chapter 
Key Terms and Technologies................................................................................................ 5 
Supported Guest Operating Systems..................................................................................... 7 
 
 

 



 Introduction 5 
 

Key Terms and Technologies 
In hopes of making your experience as effortless as possible, we’ve designed Parallels 
Workstation to be extremely user-friendly, even if you’re a computer “newbie.” This section 
highlights some of the terms you’ll need to know as you work your way through this guide.  

Virtual machine (VM): The whole point of Parallels Workstation is simulating other computers 
running inside your physical computer. This computer-within-your computer has its own 
operating system, its own software suite, and its own “screen.”  

You might call it a PC simulator, an imitation PC, or a mock computer. But in the computer-
science industry, it has a standard name: a virtual machine. Every time you start up Parallels 
Workstation, you’re actually turning on a virtual machine running Windows or any other 
operating system you want to use. 

Each virtual machine behaves as though it’s running on a PC with these components: 

 an Intel Pentium or AMD processor; 
 a generic motherboard compatible with Intel i815 chipset; 
 RAM up to 1500 MB; 
 VGA and SVGA monitor with VESA 3.0 support. After creating a virtual machine, the 

monitor resolution will be either 640x480 or 1024x768 (VGA and SVGA). Later you will 
have the oppotrunity to either install Parallels Tools with a video driver in Windows, or set 
your own screen resolution; 

 1.44 MB floppy drive (mapped to a physical drive or to an image file); 
 up to four IDE disk drives. These can be either virtual hard drives (from 20 MB up to 128 

GB each, in the form of hard drive image files) or CD/DVD-ROM drives (mapped to either 
actual drives or image files); 

 Ethernet network card compatible with RTL8029. Parallels Workstation supports bridging 
to wireless network adapters; 

 up to four serial (COM) ports (mapped to a real port, to a socket or to output file); 
 up to three bi-directional parallel (LPT) ports (mapped to real port, to printer or to output 

file); 
 2-port USB 1.1 controller; 
 AC'97-compatible sound card. Sound recording is supported; 
 a standard PC keyboard; 
 a PS/2 scroll-wheel mouse. 

A virtual machine lets you do tricks like these: 

 Simultaneously run multiple operating systems (OSes) and their programs on a single 
computer. 

 Create numerous virtual machines, each with a full set of standard virtual hardware. 
Operating systems and applications are isolated inside these virtual machines and share 
physical hardware components with the real computer. 

 Switch between operating systems without having to restart the computer 
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 Simplify your computer setup, combining them into one. The result: reduced hardware 
costs, lower operating expenses, and increased productivity. 

Primary Operating System (Primary OS): This is the operating system that loads when you hit the 
power button on your computer. 

Guest Operating System (Guest OS): This is the reason you bought Parallels Workstation: it’s a 
second, different operating system that you can run simultaneously. The guest OS on your 
computer might be Windows XP, or Linux, or any of several other operating systems—and they 
can all be running simultaneously in different windows! 

Hard Disk Image: Just as a virtual machine is a simulated PC, a hard disk image is a simulated 
hard drive. It’s actually just a file (of a size you can specify) on your real hard drive, but it looks to 
the virtual machine like its own actual drive. 

ISO Image: A file that contains the entire contents of a CD-ROM disc or DVD, commonly used 
to install a guest operating system in a VM.  

FDD Image: A file that contains the contents of a floppy disk, used to install specific guest 
operating systems, such as OS/2. 
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Supported Guest Operating 
Systems 

The current version of Parallels Workstation officially supports the following guest operating 
systems: 

Microsoft Windows Guest Operating Systems: 
 Windows Vista 
 Windows Server 2003 Standard Edition SP0 
 Windows Server 2003 Standard Edition SP1 
 Windows Server 2003 Enterprise Edition SP0 
 Windows Server 2003 Enterprise Edition SP1 
 Windows Server 2003 Web Edition SP0 
 Windows Server 2003 Web Edition SP1 
 Windows XP SP2 Professional 
 Windows XP SP2 Home 
 Windows XP SP1 Professional 
 Windows XP SP1 Home 
 Windows XP SP0 Professional 
 Windows XP SP0 Home 
 Windows 2000 Professional Edition SP4 
 Windows 2000 Server SP4 
 Windows 2000 Advanced Server SP4 
 Windows NT Workstation 4.0 SP6 
 Windows NT Server 4.0 SP6 
 Windows ME 
 Windows 98 
 Windows 95 
 Windows 3.11 
 Windows 3.1 

Linux Guest Operating Systems: 
 Red Hat Enterprise Linux WS4 
 Red Hat Enterprise Linux AS4 
 Red Hat Enterprise Linux WS3 
 Red Hat Enterprise Linux ES4 
 Red Hat Enterprise Linux ES3 
 Red Hat Linux 9 
 Red Hat Linux 8 
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 Red Hat Linux 7.3 
 Debian Linux 3.1 
 Fedora Core Linux 5 
 Fedora Core Linux 4 
 Fedora Core Linux 3 
 SUSE Linux 10 
 SUSE Linux 9.3 
 SUSE Linux 9.2 
 SUSE Linux 9.1 
 SUSE Linux 9.0 
 Mandriva Linux 10.1 
 Mandriva Linux 10 
 Mandriva Linux 9.2 
 Ubuntu Linux 5.0.4 
 Xandros Linux 4.0 

FreeBSD Guest Operating Systems: 
 FreeBSD 5.4 
 FreeBSD 5.3 
 FreeBSD 4.5 
 FreeBSD 4.1 

OS/2 and eComStation Guest Operating Systems: 
 OS/2 Warp 4.5  
 OS/2 Warp 4 
 OS/2 Warp 3 
 eComStation 1.2 
 eComStation 1.1 

Sun Solaris Guest Operating Systems: 
 Solaris 10 
 Solaris 9 

MS-DOS Guest Operating Systems: 
 MS-DOS 6.22 
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System Requirements 

Note. Before installing the product, please make sure that all computers where you wish to 
install and run Parallels Workstation meet the hardware and software requirements described in 
this section. 
 

Hardware Requirements 
The physical computer running Parallels Workstation should meet the following hardware 
requirements: 

 700 MHz processor which supports the Pentium III instructions set. 1.5 GHz or faster is 
recommended. 

 32-bit or 64-bit platform. Note that to run Parallels Workstation 2.2 on 64-bit platform you 
should have a 32-bit primary OS installed on it. 

 Memory to run the primary OS plus memory required for each guest operating system and 
its applications. Please see your primary and guest operating systems documentation for 
their memory requirements. 1 GB or more is recommended. 

 Disk space required for virtual machines should be estimated according to volume of data 
you intend to store on virtual hard disks. A typical Windows XP virtual machine after the 
system installation occupies about 2 GB on the hard disk. Parallels Workstation itself takes 
about 23 MB. 

 Any SVGA video card with an 8-bit display adapter supported by your primary OS. 16-bit 
color depth or higher is recommended. 

 Optional: a 3.5" floppy drive, a CD/DVD-ROM drive. 
 If you intend to access the Internet in virtual machines, you should have an Ethernet adapter 

installed on your computer that is supported by your primary OS. 
 Optional: serial port, parallel port, USB controller. 
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Software Requirements 
If one of the following primary operating systems is running on your computer, Parallels 
Workstation can be successfully installed on it. 

Microsoft Windows Primary Operating Systems: 
 Windows Vista 
 Windows 2003 Standard Edition SP0 
 Windows 2003 Standard Edition SP1 
 Windows 2003 Enterprise Edition SP0 
 Windows 2003 Enterprise Edition SP1 
 Windows 2003 Web Edition SP0 
 Windows 2003 Web Edition SP1 
 Windows XP SP2 Professional 
 Windows XP SP2 Home 
 Windows 2000 Professional Edition SP4 
 Windows 2000 Server SP4 

You should have Internet Explorer version 5.0 or higher installed on your computer. 

Linux Primary Operating Systems: 
 Fedora Core Linux 4 stock 2.6.11-1.1369_FC4  
 Red Hat Enterprise Linux WS4 stock 2.6.9-5  
 Red Hat Enterprise Linux AS4 stock 2.6.9-5  
 Red Hat Enterprise Linux ES4 stock 2.6.9-5  
 Red Hat Linux 9 stock 2.4.20-8  
 Debian Linux 3.1 stock 2.6.8-2-386  
 SUSE Linux 10.0 stock 2.6.13-15 
 SUSE Linux 9.3 2.6.11.4-20a  
 SUSE Linux 9.2 stock 2.6.8-24.11  
 SUSE Linux 9.1 stock 2.6.4-52  
 SUSE Linux 9.0 stock 2.4.21-69  
 Mandriva Linux 10 stock 2.6.3-7 

The following software packages should be installed: 

 Sources of currently installed kernel (if you didn't install the kernel manually, then you 
should install kernel-sources package from your distribution);  

 glibc [glibc]  
 gcc [gcc], ld [binutils] (included in any development package)  
 X Window System including  

 xf86vidmode extension (for fullscreen only)  

 



 System Requirements 11 
 

 XKB extension (for keyboard national layouts and leds support) 
 Qt 3.0.5 library multithreaded [qt3] 

PAE Support 

Current version of the Parallels Workstation supports up to 4 GB PAE (Physical Address 
Extension). If your processor supports more than 4 GB PAE: 

 In Windows primary OS on the first starting a virtual machine you will be prompted to 
create a new configuration with 4 GB PAE in boot.ini.  

 In Linux primary OS kernel PAE setting should be changed manually. 

See Troubleshooting section in Starting a Virtual Machine topic. 
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C H A P T E R  2  

Installing Parallels Workstation 

In this chapter you’ll learn how to install Parallels Workstation on your computer. Installation 
process is different in Windows and Linux primary OSes. 

In This Chapter 
Parallels Workstation for Windows: Step-by-Step Installation ............................................ 12 
Parallels Workstation for Linux: Step-by-Step Installation .................................................. 22 
 
 

Parallels Workstation for Windows: 
Step-by-Step Installation 

Note: You must have Power User or Administrator rights to be able to install the Parallels 
Workstation on a computer running Windows. 

To install Parallels Workstation: 

1 Download Parallels Workstation installation file from Parallels site.  

 To download a trial version access the Parallels Download Center 
http://www.parallels.com/en/download. 

 To buy a full-scale version visit the Parallels Buy Online page 
http://www.parallels.com/en/buyonline. 

Select the Windows EXE file for downloading.  

 

http://www.parallels.com/en/download
http://www.parallels.com/en/buyonline


 Installing Parallels Workstation 13 
 

2 Locate the downloaded self-extracting Parallels-Wst-2.2.xxxx-Win.exe file and 
double-click it. The Parallels Setup Wizard greets you with the following screen. 

 
Click Next button to display user license agreement which you must accept to continue 
installing Parallels Workstation. 

3 On the License Agreement screen use either the PgDn key or the down arrow ↓ key on your 
keyboard to read the entire agreement. Select the I accept the terms of the license agreement 
option. The Next button becomes enabled; click it to proceed with the installation.  
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You may print the license agreement for your records using the Print button. 

 
4 In the User Registration screen you can enter your contact information that will be used for 

sending you a trial activation key. Please enter your E-mail and User name. Specifying 
Company name is optional. Check I want to receive news from Parallels to my E-mail if you 
want to be informed about new Parallels products. You will be sent a free trial activation 
key soon after this. 

If you prefer to register on Parallels site, click the Register on site button. 

To buy Parallels Workstation and receive a permanent activation key, use the Buy button. 

If you want to put off the registration, click Skip registration to proceed to next step.  
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Note. The User registration screen does not appear if you reinstall Parallels Workstation. 

 
5 In the Customer Information screen, you can activate your copy of the Parallels Workstation. 

To do this, enter your Activation key. Entering User Name and Company Name is optional. 
Register on site and Buy buttons are provided for obtaining a trial activation key and a 
permanent activation key respectively. The Register on site button opens the Parallels site 
where you can register and get a trial activation key; the Buy button opens the Parallels 
online store where you can purchase a permanent activation key.  

When finished, click the Next button to move to the Choose Destination Location screen. 

Notes. 1. You are not obligated to specify activation information right now. It is possible to 
do it later in the installed application in the Activate Product window. To skip this step, 
click the Activate later button. 
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2. The Customer Information screen may not appear if you reinstall Parallels Workstation 
after removing it. If you chose to save license information when removing, this step will be 
omitted. 
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6 On the Choose Destination Location screen you should specify a folder where Parallels 
Workstation will be installed. If you are not satisfied with the default folder, click the 
Change button to find another one. Note that Parallels Workstation should be installed only 
on the bootable system disk. 

 
Press the Next button to display the Select Program Folder window. 
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7 In this window you have to define the name of the Parallels Workstation folder in the 
Programs list of the Windows Start menu. 

 
By default, setup wizard offers to create a new folder called Parallels. However, you may 
choose one of the folders currently existing in the Programs list and presented in the Existing 
Folders list on this screen.  

Click Next to proceed.  
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8 On the Select shortcuts screen, specify where Parallels Workstation shortcuts should be 
added. The first option, Create the application shortcut on the Desktop adds Parallels 
Workstation icon on the Windows desktop. The second option, Create the application 
shortcut in the Start menu adds an additional link into program folders list above the folders. 
The third option, Put the application shortcut on the Quick Launch panel adds Parallels 
Workstation icon to the Windows Quick Launch panel located in the Taskbar. 

 
Click Next to move to the next screen.  

9 On the Ready to Install the Program screen, if you are satisfied with the information entered, 
click Install to start the Parallels Workstation installation. 
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You can return to the previous steps by clicking the Back button. 

 
10 If your Windows primary system is configured to warn you every time an unsigned driver is 

installed, you will receive the following message box: 

 
Click OK to disable the unsigned driver warnings during Parallels Workstation installation. 
They will re-enabled later when the installation will be complete. 

If your system is configured to block the unsigned drivers installation, you will receive the 
similar message prompting you to allow installation of these drivers. Click OK, otherwise 
Parallels Workstation can not be installed at all. 
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11 Installation progress is shown in the Setup Status window. 

 
12 When Parallels Workstation is installed, the wizard displays its final screen. 

 
To complete the installation, click Finish. If you check I want to view Readme file option, the 
Readme file will be opened in Notepad.  
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Parallels Workstation for Linux: 
Step-by-Step Installation 

Notes: 1. Make sure that the required packages and libraries enlisted in the software 
requirements (page 10) for the Linux primary OS are installed on your system. 

2. To install Parallels Workstation on a Linux computer, you need root privileges. 

To install Parallels Workstation: 

1 Download the Parallels Workstation installation file from Parallels site.  

 To download a trial version access the Parallels Download Center 
http://www.parallels.com/en/download. 

 To buy a full-scale version visit the Parallels Buy Online page 
http://www.parallels.com/en/buyonline. 

Depending on what file types your system supports, download the RPM package, or DEB 
package, or TZG archive respectively. 

2 Launch the Terminal program. 

3 Run the 
su 

command to gain root privileges. Enter the password to the root account when you are 
asked for it. 

4 If .rpm is supported in your system: 

 Locate the .rpm package file Parallels-2.2.xxxx-lin.i386.rpm. 

 To start installing Parallels Workstation, issue the following command: 
rpm -i Parallels-2.2.xxxx-lin.i386.rpm 

Proceed to step 7. 

5 If .deb is supported in you system: 

 Locate the .deb package file Parallels-2.2.xxxx-lin.deb. 

 To start installing Parallels Workstation, issue the following command: 
dpkg -i Parallels-2.2.xxxx-Lin.deb 

Proceed to step 7. 

6 If both .rpm and .deb are not supported in your system: 

 Locate the .tgz package file Parallels-2.2.xxxx-lin.tgz and extract it into 
any existing directory: 

tar -xzpf Parallels-2.2.xxxx-lin.tgz -C <directory name> 

 Go to the directory where you unpacked the .tgz file and issue the next command 
cd parallels-2.2.xxxx-lin 

 Run the following command 

 

http://www.parallels.com/en/download
http://www.parallels.com/en/buyonline
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./install.sh 

7 After the installation completes, you should run the post-installation script. Issue the 
following command: 

parallels-config 

8 When prompted, press Enter on the keyboard.  

9 Read the license agreement up to the end by pressing Spacebar on your keyboard. To 
accept the agreement, type "y" or "yes" (in either upper or lowercase) and press Enter. 

10 The Parallels Workstation configuration procedure configures, compiles and installs drivers. 
After the process is finished you will be informed about the successful completion.  

11 In the Terminal, issue the  
exit 

command to leave the root account. You can now run Parallels Workstation! 

Troubleshooting 

If you receive a "Can not configure!" or "Can not compile!" message (note that 
you should have kernel sources installed), you can view log file and try to fix problem yourself. 
The log file is named /usr/lib/parallels/comp.log.<log number>.error 

If you can not fix the problem yourself, please send the log file and problem description to 
reports@parallels.com. We will assist you as soon as possible. 
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C H A P T E R  3  

Starting Parallels Workstation 

In This Chapter 
Starting Parallels Workstation in Windows Primary OS ...................................................... 24 
Starting Parallels Workstation in Linux Primary OS............................................................ 24 
 
 

Starting Parallels Workstation in 
Windows Primary OS 

 Select Programs --> <Parallels Folder Name> --> Parallels Workstation in the Windows Start 
menu, where <Parallels Folder Name> denotes the name of the Parallels Workstation folder 
in Windows Start menu that you have specified while installing.  

 You may also start Parallels Workstation by double-clicking its icon on the desktop, by 
single-clicking its shortcut in Start menu, or by single-clicking its icon in the Quick Launch 
panel, if you have added the corresponding shortcuts during installation. 

 
 

Starting Parallels Workstation in 
Linux Primary OS 

 Log in, launch the Terminal program and run  
parallels 

in the command line. 
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C H A P T E R  4  

Creating a Virtual Machine 

In the Parallels Workstation window click the button. Now the New Virtual 
Machine Wizard appears — a series of screens that will help you build and configure a virtual 
machine — appears. 
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Click the Next button.  

 

You'll notice the first option, Create a typical VM, is selected. We highly recommend that you 
leave this selection untouched, especially if you are new to virtualization; it's the easiest way to 
create a new virtual machine. Click Next. 
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On the next screen, you specify what guest operating system you’ll be running on your virtual 
machine. Choose the operating system from the first pop-up menu (for example, Windows), and 
then choose the version from the second one (Windows 3.1, Windows 95, Windows XP, or 
whatever). 

After specifying the guest OS, click Next. 
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In this final step, you're asked to name your virtual machine. The name doesn’t really matter 
unless you plan to create several VMs running the same operating system; in that case, you’ll 
want to give them distinct names (“Windows XP for Games” and “Windows XP for 
Work”, for example). 

This dialog box also lets you specify where you want to store the files that make up your virtual 
machine. Unless you indicate otherwise, the wizard will name the VM after the guest OS you’ve 
specified and store it in the Parallels folder. (You can change this default folder in Parallel 
Workstation’s Edit -> Preferences ->  Common dialog box. For more information, consult the full 
Parallels Workstation 2.2 User Guide by choosing Help -> Contents.)  

Click Finish to begin creating the virtual machine. When the new configuration is generated and 
opened in the Parallels Workstation window, the auto-update feature asks if you want Parallels 
Workstation to perform regular automatic checks for updates.  

 

We recommend that you turn this feature so you will be automatically informed when Parallels 
Workstation updates are released. For more information about the auto-update feature see Auto-
Updating Parallels Workstation in Windows or Auto-Updating Parallels Workstation in Linux in the 
Parallels Workstation 2.2 User Guide. You can access the guide by selecting the Help -> Contents 
drop-down menu in the Parallels Workstation menu bar. 

Next, you will need to activate your copy of Parallels Workstation. 
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C H A P T E R  5  

Activating Parallels Workstation 

Before installing a guest operating system onto your first virtual machine, you must activate 
your copy of Parallels Workstation. You will be not able to power on a virtual machine until 
your copy of the Parallels Workstation is activated with a trial or a permanent activation key. 

In This Chapter 
Activating Parallels Workstation in Windows Primary OS .................................................. 29 
Activating Parallels Workstation in Linux Primary OS........................................................ 31 
 
 

Activating Parallels Workstation in 
Windows Primary OS 

The installation wizard allows you to enter your activation key during Parallels Workstation 
installation. If you have not done this, perform the following steps. 

Getting an Activation Key 

If you already have an activation key, skip this section and proceed to Activating Your Copy of 
Parallels Workstation below in this topic. 

To get an evaluation key: 

1 Click Help in the menu and select Activate Product. This opens the Activate Product screen. 

2 In the Activate Product screen, click the Evaluate button to open the User Registration 
window.  
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3 In the User Registration window, specify your e-mail and your name. Entering the name of 
your company and optional information in the respective tab is not necessary. Specify if you 
want to receive news from Parallels to your e-mail. 

 
4 Click the Register button to send this information to Parallels. You will be sent a free trial 

activation key to your e-mail in a short time. 

Alternatively, you may register on Parallels site. Use the Register on site button to proceed 
to creation of the account on site. You will receive a free trial activation key on your e-mail 
soon after this.  

To get a permanent activation key: 

1 Click Help in the menu and select Activate Product. This opens the Activate Product screen. 

2 In the Activate Product screen, click the Buy button to open the Parallels Online Store where 
you can purchase a permanent activation key. 

Activating Parallels Workstation 

Perform the following steps: 

1 Click Help in the Parallels Workstation main menu and select Activate Product.  
2 In the Activate Product window fill in the following fields:  

 In the Activation key field, type the key provided to you. When you fill in this field, the 
Activate button becomes active.  
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 Specify your name and name of your company in the User Name and Company Name 
fields. Information taken from Windows system settings is automatically prompted here. 
These fields are optional. 

 
3 Click the Activate button. If you have entered a valid activation key, the following 

confirmation message will be displayed: "Parallels Workstation has been 
activated successfully. Thank you!" From this point on your copy of the 
Parallels Workstation is active and you may use all of its features and capabilities. 

 
 

Activating Parallels Workstation in 
Linux Primary OS 

Getting an Activation Key 

If you already have an activation key, skip this section and proceed to Activating Your Copy of 
Parallels Workstation below in this topic.  

To get an evaluation key: 

1 Click Help in the menu and select Activate Product. This opens the Activate Product screen. 

2 In the Activate Product screen, click the “obtain a free trial activation key” link to open the 
User Registration window.  
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3 In the User Registration window, specify your e-mail and your name. Entering name of your 
company and optional information in the respective tab is not necessary. Specify if you want 
to receive news from Parallels to your e-mail. 

 
4 Click the Register button to send this information to Parallels. You will be sent a free trial 

activation key to your e-mail in a short time. 

Alternatively, you may register on Parallels site. Click the Register on site button to proceed 
to creation of the account on site. You will receive a free trial activation key on your e-mail 
soon after this. 

To get a permanent activation key: 

1 Click Help in the menu and select Activate Product. This opens the Activate Product screen. 

2 In the Activate Product screen, click the “purchase a permanent activation key” hyperlink to 
open the Parallels Online Store. 

Activating Parallels Workstation 

To activate Parallels Workstation in Linux do the following: 

1 Click Help in the Parallels Workstation main menu and select Activate Product.  
2 In the Activate Product window, fill in the following fields:  

 In the Activation key field type the key provided for you. When you fill in this field, the 
Activate button becomes active.  
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 Specify your name and name of your company in the User Name and Company Name 
fields. These fields are optional. 

 
3 Click the Activate button. If you have entered a valid activation key, the following 

confirmation message will be displayed: "Parallels Workstation has been 
activated successfully. Thank you!" From this point on, your copy of the 
Parallels Workstation is active and you may use all of its features and capabilities. 
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C H A P T E R  6  

Installing a Guest Operating System 

When it comes to installing the guest OS, you will have a few options. You can install directly 
from a CD/DVD or floppy disk, or install the OS from an image of any of these disks. All kind 
of disk images can be made using the Parallels Image Tool included in the Parallels Workstation 
distribution. See the Using the Parallels Image Tool chapter in Parallels Workstation 2.2 User 
Guide, which is accessible through the Help->Contents menu in the menu bar.  

Note: To install a guest OS from any physical disk when running Linux primary OS, you should 
have system privileges to access the corresponding device of your host computer. Otherwise 
you will not be able to connect CD/DVD-ROM or floppy drive of your virtual machine to 
proper physical device. 

Here are the General Steps: 

1 Start Parallels Workstation.  

2 Either open a virtual machine you previously created or choose to create a new one. 

To open the virtual machine you've just created, click File menu and select the name of the 
configuration file in the end of the list. 

To install from a physical CD/DVD or CD/DVD .iso image: 

1 In the Parallels Workstation window, click on the  CD/DVD-ROM 1 in the Resources list. 
This opens the Configuration Editor window with CD/DVD-ROM Options. 

Important: Make sure that the Enabled and the Connect at startup options are selected. 

2 Connect the CD/DVD-ROM drive to the guest OS distribution. For this, do the following. 

If you want to install from a real CD/DVD:  

In the CD/DVD-ROM Options screen, click the Use real CD/DVD-ROM option and specify 
which real drive to connect to the virtual device in the CD/DVD-ROM Drives list. 

Now simply insert the CD/DVD disk with the operating system distribution into the 
appropriate drive of your computer. 

If you’re installing from an .iso image file: 

In the CD/DVD-ROM Options screen, click the Use image file option and specify the path 
to the .iso distribution file in the Image File field. 

3 In the Connect to list select IDE 0:1. This enables not just reading but installing guest OS 
from the selected CD/DVD-ROM drive. 

4 Now that we’ve made all of these changes, it is essential that you save the virtual machine 
configuration.  In order to do this: 

Click OK on the Configuration Editor screen, then click the  button in the 
Parallels Workstation window or select Save in the File menu. 
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5 Now, start the virtual machine by clicking Power On  on the toolbar. Capture the input 
devices in the guest OS screen as we discuss in the chapter Capturing and Releasing 
Keyboard and Mouse in a Virtual Machine (page 39). All you have to do now is follow the 
installation instructions for the specific operating system.  

If you receive a PAE warning on virtual machine startup, see the Troubleshooting subtopic 
below for instructions on correcting the problem. 

To install from a physical floppy disk or a floppy image: 

1 In the Parallels Workstation window, click on the  Floppy in the Resources list. This 
opens the Configuration Editor window with Floppy Options. 

Important: Make sure that the Enabled and the Connect at startup options are selected. 

2 Connect the floppy drive to the guest OS distribution. For this, do the following. 

If you want to install from a real floppy disk: 

In the Floppy Options screen, select the Use real floppy option and specify which real 
drive to connect to the virtual device in the Floppy Drives list. 

Insert the floppy disk with the operating system distribution into the appropriate drive of 
your computer. 

If you're installing from an .fdd image file: 

In the Floppy Options screen, check the Use image file option and specify the path to the 
.fdd distribution file in the Image File field. 

3 Now that we’ve made all of these changes, it is essential that you save the virtual machine 
configuration.  In order to do this: 

Click OK on the Configuration Editor screen, then click the  button in the 
Parallels Workstation window or select Save in the File menu. 

4 Now, start the virtual machine by clicking Power On  on the toolbar. Capture the input 
devices in the guest OS screen as we discuss in the chapter Capturing and Releasing 
Keyboard and Mouse in a Virtual Machine (page 40)). All you have to do now is follow the 
installation instructions for the specific operating system.  

If you receive PAE warning on virtual machine startup, see troubleshooting sections below 
for instructions on correcting the problem. 
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Troubleshooting 

In Windows Primary OS

If when starting a virtual machine in Windows primary OS you receive the warning 
"Parallels Workstation has detected that your primary operating 
system is running in PAE mode...", this means that your host computer 
configuration does not conform to Parallels Workstation requirements. Current version of the 
Parallels Workstation supports up to 4 GB PAE. To bypass this problem: 

 Follow Parallels Workstation prompts to create new configuration with 4 GB PAE. 
 Boot into this configuration. When launching Windows primary OS select the configuration 

that has in parentheses "for Parallels Workstation" on the Please select the 
operating system to start screen. 

In the future boot into the Windows configuration with 4 GB PAE to work with Parallels 
Workstation. 

In Linux Primary OS

If when starting a virtual machine in Linux primary OS you receive the warning "Parallels 
Workstation can not be started due to VM memory mapping fail..." 
or when running a guest OS you receive the warning "Parallels Workstation 
experience problem when trying to allocate physical memory in 
PAE mode...", it could mean that the currently running kernel supports PAE greater than 4 
GB physical memory while the current version of Parallels Workstation supports up to 4 GB 
PAE only. To fix the problem you have to change the auto detected PAE value to 4096 MB. Do 
the following: 

 Add to your boot loader the kernel option "mem=4096M" (refer to your boot loader 
documentation for details). 
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Parallels Tools 

Although Parallels Workstation lets your guest OS access your computer's video card, network 
cards, and other hardware, it also simulates its own set of PC hardware (Key Terms and 
Technologies (page 5) topic).  

If you’ve installed Windows (except 3.1), Solaris, OS/2, or eComStation, Parallels provides 
special add-ons called Parallels Tools that improve some hardware components and add helpful 
extra features. For example, they let you: 

 use higher resolution and color depth for the guest OS monitor, 
 use the cursor in the guest OS without pressing a special key combination,  
 share the same clipboard between your guest OS and primary OS, so that you can exchange 

text and pictures, 
 improve network connections and sound quality.  

Note: In a Solaris guest OS, a network driver is required to support networking in a virtual 
machine. 

Parallels Tools can be easily installed manually after completing the guest OS installation. 

Installing Parallels Tools in a Windows guest OS is described below. For other guest OSes, 
please refer to the Creating Virtual Machine->Installing Parallels Tools section of the Parallels 
Workstation 2.2 User Guide, which is available through the Help->Contents menu in the menu 
bar. 

Installing Parallels Tools in Windows 

To install Parallels Tools in a Windows guest OS, do the following: 

1 First, boot your guest OS and log in. In order to install tools properly, do not begin the 
installation until the OS completes its startup and you are logged in. 

2 Select Install Parallels Tools in the Parallels Workstation VM menu.  

3 You are warned about the necessity of having your guest OS fully started and logging in: 
"You can install the Parallels Tools only if the guest 
operating system is running and you are logged in. If you are 
not logged in now, select Cancel and run Parallels Tools 
installation later." If you are logged in, click OK to start installing.  

4 The Parallels Tools Setup wizard starts and greets you. Click Next to move to the Choose 
Destination Location screen. If you do not like the default directory, select another one using 
the Change button. Then click Next. 

5 On the Setup Type screen you should choose between the complete setup and a custom 
one. The complete setup installs all of the tools available for your guest OS. If you select 
custom setup, the Select Components screen asks you to select the desired tools from the 
tools available for your guest OS. 
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6 Choose the program folder on the Select Program Folder screen, then the Check Setup 
Information screen displays the options selected. If they are correct, click Next to begin the 
installation. 

7 By default a Windows operating system is configured to warn you every time an unsigned 
driver is installed. Parallels Tools installation wizard supposes to temporarily disable these 
warnings.  

When you receive the following message: "Parallels Tools installation 
contains a number of unsigned drivers. These drivers are 
required for proper functioning of Parallels Tools. Currently 
your system is configured to warn you every time an unsigned 
driver is installed. Do you want to receive these warnings 
during Parallels Tools installation?" click OK to disable the unsigned 
driver warnings during Parallels Tools installation. They will re-enabled later when the 
installation will be complete. 

8 After the wizard copies the tools, the Installation Completed screen asks if you want to 
restart the computer now. In all Windows guest OSes, except 98 and NT, you must restart 
the virtual machine after this setup procedure. Click Finish, and your virtual machine will be 
restarted and ready for work with the tools installed. 

Note: In Windows 98 and Windows NT some drivers require additional steps to perform after 
this setup. Please refer to the Creating Virtual Machine->Installing Parallels Tools section of the 
Parallels Workstation 2.2 User Guide, which is available through Help->Contents in the menu bar. 

Troubleshooting When Installing Tools 

Parallels Tools installation is invoked by the Windows AUTORUN feature for the CD/DVD-
ROM drive. It is enabled by default, however if you have disabled it manually, nothing happens 
after you select the Install Parallels Tools command. (In either case, the vmtools.iso CD 
image will be connected to the virtual machine CD-ROM drive, however it is not visible to the 
user.) To solve this problem do one of the following: 

 Enable the AUTORUN function for the CD-ROM drive in your Windows guest OS. 
 Start the tools installation manually. 

Open the contents of the vmtools.iso in Windows Explorer, find PrlTools.exe file, 
and start it. 

 

 



 39 
 

C H A P T E R  8  

Capturing and Releasing the Keyboard 
and the Mouse in a Virtual Machine 

When you power up a virtual machine, you’ve got two computers running at once: your actual 
computer, and the simulated PC that’s running inside it. But you’ve got only one mouse and 
keyboard! How, then, is Parallels Workstation supposed to know when a certain mouse or 
keyboard activity is intended for the primary OS, and when for the guest OS? 

The Automatic Handoff 

One obvious answer is: Whenever the cursor is inside the guest OS window, then it belongs to 
that OS. When the cursor moves out of the guest window, it belongs to the primary OS once 
again. 

And indeed, that’s exactly how things work if you’ve installed Parallels Tools as described in 
the previous chapter. 

The Manual Handoff 

But Parallels Tools are not available for all guest operating systems; furthermore, some people 
may prefer to trigger the keyboard/mouse handoff manually. You can use any of three methods 
to make the virtual machine “capture” the keyboard and mouse: 

 Click anywhere inside the virtual machine window.  
 Select Capture Input in the VM menu. 
 Press Ctrl+I on your keyboard.  

Once the guest OS captures your cursor, you can’t move it outside of the Parallels Workstation 
window until you release it. 

To release the keyboard and mouse to primary OS: 

 Press the keyboard shortcut for releasing your keyboard/mouse. The factory setting is 
Ctrl+Alt, but you can change this key combo in the Edit -> Preferences -> Hot Keys tab. 

The keyboard and the mouse will be released immediately.  
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Keyboard Shortcut Limitations in 
Windows Primary OS 

If your computer is running Windows primary OS, it will intercept Ctrl+Alt+Del key 
combination pressed in guest OS. To send Ctrl+Alt+Del to guest OS: 

 either press Ctrl+Alt+Ins while the keyboard is captured inside a Virtual Machine 
window, 

 or select Send Ctrl+Alt+Del in the Parallels Workstation VM menu. 
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Starting, Stopping, and Resetting a 
Virtual Machine 

Starting a Virtual Machine 

Once you’ve set up a virtual machine and installed a guest OS, Parallels Workstation is ready 
for work whenever you are. 

Just click the Power On  button on the Parallels Workstation toolbar (or choose VM -> Power 
On). The virtual machine switches on, its control panel opens in the Parallels Workstation 
window, and the guest OS “boots up,” looking just as it would on a real PC.  

Note that the virtual machine can only be powered on if your copy of Parallels Workstation has 
been activated with a permanent or trial activation key. If your copy is not activated, the "This 
copy of Parallels Workstation is currently not active" warning will 
appear. If this is the case, you will need to go back and activate your copy (see the Activating 
Parallels Workstation (page 29) chapter). 

Stopping a Virtual Machine 

You shut down your virtual machine just as you would on a real PC. For example, if you’re 
running Windows, you click the Start button and click Shut Down. Only if you can’t stop the 
guest OS this way, you may use the Parallels Workstation controls to do so, like this: 

 Click the Power Off  button on the Parallels Workstation toolbar, 
 Choose VM -> Power Off in menu. 

Resetting a Virtual Machine 

You should always restart a guest OS using its built-in Restart command. For example, in 
Windows, click Start, then Shut Down, then Restart.  

If that doesn’t work, for some reason, only then should you use the Parallels Workstation 
controls, using one of the following options: 

 Click the Reset button on the Parallels Workstation toolbar (or select VM->Reset ). 
 Select Send Ctrl+Option+Del in the VM menu (or press Ctrl+Alt+Del(Ins) while the 

keyboard is captured inside a virtual machine window). 
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Running a Virtual Machine in Fullscreen 
Mode 

In order to make a virtual machine feel even more like a regular computer, you may sometimes 
want to expand the guest OS screen so that instead of huddling in a window, it occupies your 
entire monitor, edge to edge.  

In this fullscreen mode, primary OS and all of its programs are hidden. The Parallels 
Worksatation menu, toolbar, and status bar will be hidden as well.  

If you want to run the virtual machine in fullscreen mode, make sure it’s already running. Then 
do one of these three things: 

 click the Fullscreen Mode  toolbar button,  
 select View->Fullscreen in the menu, 
 press Alt+Enter on your keyboard. 

To shrink the virtual machine screen to the usual (windowed) mode: 

 press Ctrl+Alt or Alt+Enter on your keyboard.  
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Accessing the Internet 

If you want to access the Internet in a virtual machine, start by making sure your computer can 
itself get online.  

Then proceed like this:  

1 If your virtual machine is currently running, turn it off (click its Power Off  button). You 
can change a VM's configuration only when it’s shut down.  

2 In the Parallels Workstation window, click Network Adapter in the Resources list to open the 
Configuration Editor screen which contains the Network Adapter Options. 

 
3 In Network Adapter Options, make sure that the Enabled and Connect cable at startup options 

are selected. In the Emulation group, select the Bridged Ethernet option and then choose a 
name of your network adapter in the list: 

 default adapter to use the adapter which connects to the Internet your real compter, 

 or a specific adapter if you have a different one installed. 

4 Next, click OK on the Configuration Editor screen, then click the  button 
in the Parallels Workstation window (or choose File -> Save). 
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5 Now, start the virtual machine by clicking Power On on the toolbar. Capture the input 
devices in the guest OS screen (Capturing and Releasing Keyboard and Mouse in a Virtual 
Machine (page 39) chapter), if necessary. 

6 Configure network options in your guest operating system, just as you would on a new PC.  

Once you’re connected to the Internet, you can use your virtual machine to access email, surf 
the web, chat, and more! 
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Creating Shared Folders 

Having Parallels Tools installed lets you to transfer texts and small pictures between your main 
computer and virtual machine. To be able to exchange files you should setup shared folders. 
Shared folders are folders in your primary OS that are visible to the guest OS also. In your 
computer shared folders appear as usual folders, while in guest OS they are objects of the 
network neighborhood. 

Using shared folders is possible for the following guest OSes:  

 Window 2000/XP/2003. 

Adding a Shared Folder 

1 Open the virtual machine configuration, click the  button to open the 
Configuration Editor. 

2 In the Configuration Editor, select the Shared Folders tab. Select the Enable shared folders 
option. 

 

3 In the Shared Folders tab, click the   button to open the Shared Folder Properties dialog 
box. 
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4 In the Shared Folder Properties dialog box: 

specify a name for the folder which will appear in your guest OS in the Name field; 

specify a folder in the file system your primary OS that will be shared in the Path field; 

if you want to restrict writing to this folder from inside the guest OS, select the Read Only 
check box. You will be able to save files to this folder in the primary OS only; 

make sure the Enabled check box is selected; 

and click OK. 

 
5 Click OK in the Configuration Editor. 

6 Click  to save the virtual machine configuration. 

Note. To view the content of shared folders in a virtual machine you should have Parallels Tools 
installed. Refer to the Parallels Tools (page 37) chapter.  

Viewing Shared Folders 

To view the contents of the shared folders in the guest OS: 

1 Start the virtual machine. 

2 Open Windows Explorer. 
3 In the Explorer, select My Networks Places, then select Entire Network, and find the Parallels 

Shared Folders. 

4 Click the Parallels Shared Folders to view the list of shared folders available in your virtual 
machine. 
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When working with a shared folder inside a virtual machine, keep in mind that the ability to 
save files into this folder depends on its Read Only setting. 
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How to Build a Windows XP Virtual 
Machine 

Many users are going to create a Windows XP virtual machine, and this section will give you a 
step-by-step description of how to do that. Here we go: 

 Start Parallels Workstation as we discussed in the Starting Parallels Workstation (page 24) 
section. 

 Create a virtual machine for Windows XP.  

To initiate this process use either the button or the File->New VM menu 
item. Follow the steps of the New Virtual Machine Wizard as described in the Creating a 
Virtual Machine (page 25) section.  

 Now we are ready to install the Windows XP guest operating system. Insert the installation 
CD or DVD with the full version of Windows XP into the CD/DVD-ROM drive of your 
computer. 

 Click the Power On  button to start the virtual machine. Installation starts, and the 
Welcome to Setup screen is shown soon. 

 
Now you’ve got two computers running at once: your actual PC, and the simulated 
computer that’s running inside it. But you’ve got only one mouse and keyboard! How, then, 
is Parallels Workstation supposed to know when a certain mouse or keyboard activity is 
intended for your primary OS, and when for the guest OS? To start communicating with 
virtual machine, you have to capture your mouse and keyboard inside the virtual machine: 
click somewhere inside the Windows XP screen. 
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Note. You can return to your primary OS at any time by pressing Ctrl+Alt on your 
keyboard. 

After this press Enter on your keyboard. 

 The license agreement is displayed on the screen. To scroll down press the Pagedown key. 
To agree press F8. 

 
 In the lower part of the following screen, the Setup displays the list of hard disks and 

partitions available in the virtual machine. You should have the only one item, the 
unpartitioned space. Press Enter to set up Windows XP on this object.  
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 After this, you’ll have to choose how to format your system volume. It is best to format the 
Windows XP system disk using NTFS quick formatting method. So, select the type of file 
system and mode of formatting and press Enter. 

 
 The virtual machine will restart automatically. The text stage of the installation is 

completed. During the next stage, dialog boxes will be used. Select your Regional and 
Language Options and proceed to entering license key. Type it and click Next. 
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 On the next several screens you will be asked to enter computer name and administrator 
password, select your date and time zone, specify your network setting (we recommend to 
select typical ones).  

 Next, you have to specify whether your computer will be a member of a domain. If you are 
creating the virtual machine for running it in corporate environment, ask system 
administrator whether you should specify the domain. Otherwise, choose the first option to 
make your virtual machine a member of workgroup. 
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 After that, Setup adjusts the Display Settings for better image quality. 
 In the Help protect my PC screen indicate whether you want to turn on the Automatic 

Updating feature. We recommend to turn automatic updates on. 
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 As the next step, choose the way your computer will be connected to the Internet. Select 
Yes. 

 
 If you want to register with Microsoft specify this in the following screen. 
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 Setup prompts you to create user accounts for each person who will use this virtual 
machine. 

 
 Install Parallels Tools. Refer to the Parallels Tools (page 37) topic or to Creating Virtual 

Machine/Installing Parallels Tools section in the User Guide.  
After installation of Parallels Tools, you will be able to move the cursor smoothly between 
your guest Windows XP and primary OS without pressing Ctrl+Alt. 

 Configure the virtual machine for your needs. 
Connect the virtual machine to the Internet or create a host-only network (refer to the 
Accessing the Internet (page 43) topic or to the Managing Virtual Machines / Networking in 
Virtual Machine section in the User Guide). 

To make the file exchange between primary OS and your virtual machine easier, create 
shared folders as discussed in the Creating Shared Folders (page 45) topic. 

After this, you’ll be ready to install programs and applications in your new Windows XP virtual 
machine. Enjoy the convenience of Windows XP and your primary OS side-by-side! 
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